Condições SE NÃO

Bem, esta é mais um tipo de condição possível de aparecer em alguns exercícios.

Normalmente a gente insere a condição SE para verificação lógica. Mas o SENAO é bastante importante, por exemplo, quando não atende a primeira regra ele deve realizar determinada operação. Isso é uma grande ajuda para cálculos e até mesmo verificação lógica do que foi inserido pelo usuário. É quase impossível não usá-la dentro de programação. Por isso, vamos estuda-la bem, para que a gente tenha um melhor desempenho dentro da linguagem que escolhermos.

Vamos lá.. como de costume, assista o video tutorial, e depois se quiser baixe o vídeo.

Abaixo, a estrutura do algoritimo para funcionar dentro do Visualg.


algoritmo "aprovado_reprovado"
// Função : Verifica se está aprovador ou reprovado
// Autor :  Adriano Hedler
// Data : 20/11/2008
// Seção de Declarações
var
nota1, nota2, media :real

inicio

// Seção de Comandos

Escreval ("Digite a primeira nota")
Leia (nota1)
Escreval ("Digite a segunda nota")
Leia (nota2)
media <- (nota1 + nota2) / 2

se (media >= 70) entao
Escreval("Você foi aprovado")
senao
Escreval ("Você foi reprovado")
fimse

fimalgoritmo

Para acompanhar… assista o vídeo:


Sobre este texto